يلتزم Blackboard Collaborate بجعل تجربة التدريس والتعلم عبر الإنترنت متسقة عبر جميع المستعرضات المدعومة

دعم المستعرض

المستعرضات المدعومة

سياسة دعم إصدار مستعرض Collaborate

ماذا نعني بالدعم؟

يعني الدعم أننا اختبرنا إصدار Collaborate على أحدث إصدارين من المستعرضات المدعومة، وقمنا بالتحقق من صحة التجربة على هذه الإصدارات فقط.

وبشكل عام، مع الأخذ في الاعتبار بتعديلات أنواع المستعرض والإصدارات وأنظمة تشغيل الكمبيوتر، يتم اختبار كل إصدار من خلال عشرات التكوينات. يعد دعم أحدث إصدارين من المستعرضات الرئيسية الهدف الذي يمكننا تعيينه مع الاحتفاظ بدورات إصدار مناسبة. إن إضافة المزيد من الإصدارات تعني إضافة المزيد من وقت الاختبار، وبالتالي إطلاق الميزات لاحقًا لجميع العملاء.

على الرغم من أنه يمكنك في معظم الحالات الانضمام إلى جلسة من خلال إصدار أقدم من الإصدارين الأخيرين، فقد لا تحصل على أفضل تجربة، ولا يمكننا ضمان استخدام مستعرض Collaborate مع تلك الإصدارات.

لا يزال بإمكان المستخدمين في إصدارات المستعرض الأقدم إرسال طلبات الدعم الخاصة بالمشكلات التي يواجهونها. سيحاول فريق دعم Blackboard تكرار المشكلة مع المستعرضات المدعومة، وإذا لم يكن من الممكن تكرارها، فسوف يوصي بتحديث المستعرض إلى إصدار حالٍ من شأنه حل المشكلة.

دعم الإصدار

كجزء من التزامنا بتجربة متسقة عبر المستعرضات، يدعم Collaborate فقط أحدث إصدارين من القنوات المستقرة من المستعرضات.

ويمكن أن تقدم إصدارات المستعرض الأقدم مشكلات قد يتم إصلاحها أو لا من قِبل الشركات التي تُصدر المستعرض.

  • الأداء: يمكن أن تواجه إصدارات المستعرض الأقدم مشكلات تؤثر على أداء مستعرض Collaborate.
  • الأمان: قد تواجه إصدارات المستعرض الأقدم مشكلات أمنية وأخطاء معروفة يتم جعلها عامة. يمكن استغلال هذه المشكلات وتعريضنا ومستخدمينا للخطر.
  • التقنية القديمة: يمكن أن تكون إصدارات المستعرض الأقدم قديمة ولا تحتوي على التقنية والوظائف اللازمة لمستعرض Collaborate.

غالبًا ما تقوم شركات المستعرض بإصلاح المشكلة في إصدار أحدث، وتقوم في نهاية الأمر بإنهاء الدعم على الإصدارات الأقدم. ونتيجة لذلك، يقوم Collaborate باختبار أحدث إصدارين مستقرين من المستعرضات المدعومة والتحقق منهما.

الإصدارات المعطلة

في بعض الحالات الخاصة، نضطر إلى منع بعض المستعرضات الأقدم من الوصول إلى Collaborate. نحن نتفهم عبء العمل الذي يمكن أن تمثله ترقية المستعرضات لمؤسسة ما، ولا نتخذ هذا القرار أبدًا باستخفاف، ونقدم أكبر قدر ممكن من التحذير المسبق. يتم إجراء ذلك فقط عندما يتسبب المستعرض في حدوث مشكلات خطيرة.

  • تجربة مستخدم غير متسقة. لم يحصل المستخدمون على ميزة مهمة متاحة في المستعرضات الأخرى.
  • معدلات انقطاع عالية تمنع المستخدمين من المشاركة الكاملة في جلسة.
  • مشكلات خطيرة في المستعرض الأقدم يتعذر علينا إصلاحها أو إيجاد حلول لها، ولكن تم إصلاحها في إصدار مستعرض أحدث.
  • مخاطر أمنية محتملة.

في حين أنه قد يكون من غير الملائم أن تضطر إلى ترقية المستعرضات لمؤسسة كاملة، فكلما اضطررنا إلى تعطيل مستعرض ما، فإن ذلك في النهاية لمنع المستخدمين من الوقوع في موقف قد يتعرضون فيه لتجربة مستخدم سيئة للغاية مع هذا المستعرض.