本主题适用于使用 Blackboard Learn 9.1 2014 年 4 月份版本或更高版本的用户。如果您使用 Blackboard Learn 9.1 2014 年 10 月份版本(或更高版本)或 Learn SaaS,则本帮助主题不适用于您。要详细了解您当前所用的 Blackboard Learn 版本支持哪些浏览器,请参阅本节中的“支持的浏览器”。

常见问题

如果您使用 Microsoft Internet Explorer 访问 Blackboard Learn,可能会遇到以下两个常见错误:

  • 未登录:如果您尝试访问个人资料等云功能,且未配置浏览器,让其在同一个安全区域同时具有云服务器和 Learn 安装服务器,则会出现该错误。
  • 没有找到配置文件:如果您尝试访问个人资料功能,且配置了浏览器,让其在兼容性视图模式下显示 Learn 安装服务器或云服务器,则会出现该错误。

即使您成功登录到您机构的 Blackboard Learn,也会发生此类错误。

兼容性视图和安全区域配置是 Internet Explorer 的独特功能。如果您使用 Blackboard Learn 支持的其他浏览器,则不会遇到这些问题。有关所支持浏览器的详细信息,请参阅本节中的“浏览器支持策略”主题。

此类问题易于纠正,但是必须在各个浏览器中进行。以下部分针对几个版本提供了说明。


为 Blackboard Learn 和 Cloud 配置 Internet Explorer 安全区域

  1. 工具菜单上选择 Internet 选项。在 Internet Explorer 9 和 10 版本中,您可选择搜索栏下的齿轮图标来访问此菜单。以下步骤对于所有版本是相同的。
  2. Internet 选项对话框中选择安全
  3. 选择受信任的站点(绿色复选标记图标)。
  4. *.cloud.bb 添加到可信区域中(如果尚未添加)。
  5. 将 Blackboard 服务器地址添加到可信区域中(如果尚未添加)。
  6. 关闭受信任的站点对话框。
  7. 选择确定以关闭 Internet 选项对话框。


为 Blackboard Learn 和 Cloud 配置兼容性视图设置

  1. 工具菜单上选择兼容性视图设置。在 Internet Explorer 9 和 10 版本中,您可使用 Alt 键来显示菜单栏,从而访问此菜单。在 Windows 8 OS 上的版本 10 中,您必须处于桌面模式。以下步骤对于所有版本是相同的。
  2. 复查已添加到兼容性视图中的网站列表中的所有站点。
  3. 如果该列表上有任何 cloud.bb 站点或 Blackboard Learn 站点,请选择这些站点,然后选择 删除
  4. 如果 Blackboard Learn 站点处于 Intranet 安全区域中,请清除在兼容性视图中显示 Intranet 站点复选框。
  5. 选择 关闭,以关闭兼容性视图设置对话框。


注释

技术上来讲,如果 Blackboard Learn 服务器和 Blackboard cloud.bb 服务器处于两个不同的 Internet Explorer 安全区域中,其中一个区域在保护模式下运行,另一个区域在非保护模式下运行,则会出现安全区域问题。在此配置中,cloud.bb 服务器和 Blackboard Learn 服务器无法相互通信以验证会话,因此 cloud.bb 服务器会报告您未登录。

因此,还可以通过更改其中一个区域的保护模式设置(使用上面介绍的“安全”标签)以使其与另一个区域匹配来修复此问题,而不一定需更改任一服务器的区域或将任意一个添加到“受信任的站点”区域。但是,这可能会影响您对其他非 Blackboard 站点的浏览,或是影响您机构中的浏览策略。

推荐的通过配置浏览器解决此问题的最简单方式是按如上所述将两个条目添加到“受信任的站点”区域。

Blackboard Learn 的任何功能都应不需要兼容性视图模式。如果设置了此模式,则 Cloud 服务器无法在具有新信息时与 Blackboard Learn 服务器进行反馈通信。