浏览器支持

本页内容

    浏览器支持

    Blackboard Learn 是一款基于浏览器的应用程序。借助它,您可以展开工作并提交作业和其他课程作业。使用这些资源可确定您的 Web 浏览器是否与您机构的 Learn 版本兼容。

    为了使用您的屏幕阅读器获得最佳 Blackboard Learn 体验,请在 Windows® 系统上使用 Firefox® 和 JAWS®。在 Mac® 系统上,请使用 Safari® 和 VoiceOver。请访问无障碍访问主题,详细了解 Blackboard 用于访问可访问软件的方法。

    支持的浏览器

    要详细了解 Blackboard 的常规浏览器支持策略以及了解有关 Javascript、Cookie 和其他软件的信息,请参阅“浏览器支持策略”主题。

    支持的浏览器
     桌面操作系统浏览器版本移动设备和平板电脑操作系统浏览器版本*
    Android 浏览器不支持4 及更高版本
    Chrome**36 及更高版本35 及更高版本
    Edge**20 及更高版本20 及更高版本
    Firefox**31 及更高版本不支持
    Internet Explorer***11 及更高版本不支持
    Safari6 及更高版本6 及更高版本

    *虽然用户可能已成功使用上述浏览器的移动版本,但目前 Blackboard Learn 9.1 不支持此类版本。带来 Ultra 体验的 Blackboard Learn 与移动设备和平板电脑设备上的以下浏览器兼容。

    **Google Chrome(42 及更高版本)、Mozilla Firefox(52 及更高版本)和 Microsoft Edge 不支持 NPAPI 类型的插件,包括 Java 插件和许多媒体浏览器插件。Blackboard 不支持在以下情况下使用这些浏览器:1) 要求使用第三方 NPAPI 插件才能观看的嵌入式媒体文件,以及 2) Content Collection 中的多个文件上传界面,虽然这些浏览器支持其他多个文件上传界面。

    ***Ultra 体验或 Ultra 课程视图不支持 Internet Explorer。


    测试的设备和操作系统

    我们使用多种设备和操作系统来测试支持的浏览器。支持不局限于这些特定的操作系统。上述桌面浏览器版本也受支持,而与运行其的特定设备或操作系统无关。

    用于测试的设备
    类别测试的
    操作系统Windows 7、Windows 8、Windows 10、Mac OS 10.8、Mac OS 10.9、Mac OS 10.10、iOS、Android、Windows Mobile、Chrome OS
    iOS 设备iPod Touch、iPhone 4S、iPhone 5S、iPhone5c、iPhone 6、iPad 2、iPad 3、iPad Mini 3、iPad Air 2
    Android 设备Galaxy S4、Galaxy S5、HTC G1、LG C800 myTouch、HTC One、Galaxy Note 2014、HTC One M8
    Windows 移动设备Venue 8 Pro、Lumia 520、Lumia 930
    Chrome OS 设备Chromebook(Chrome 浏览器;要求使用 NPAPI 插件的功能不受支持)

    Blackboard 致力于使全部产品都具有尽可能高的无障碍访问性。在测试每个 Blackboard Learn 版本的无障碍访问期间,我们都使用了两个最新版本的 JAWS。

    Java 和其他浏览器插件

    有几个 Blackboard Learn 功能需要安装特定的附加软件。没有这些软件,这些功能本身无法运行。以下 Blackboard Learn 功能需要安装插件:

    • 课程文件和 Content Collection 中的多个文件上传要求将 Oracle 提供的 Java 运行时环境 (JRE) 启用作为浏览器插件。单个文件上传工具没有此要求。上传小程序由 Blackboard 签名,包括一个允许该小程序运行(甚至可在证书过期之后)的时间戳授权。
    • 课程房间和 Blackboard Collaborate 的同步交流功能(通过 Building Block 提供)要求下载和安装 Blackboard Collaborate Launcher,但不要求 Java JRE 浏览器插件。

      只有具有原始体验的 Blackboard Collaborate 才要求使用该 Launcher。带来 Ultra 体验的 Blackboard Collaborate 不要求下载任何内容。

    JRE 版本 7 和 8 是针对依赖于它的功能的推荐版本。JRE 版本 6 可以工作,但是可能导致意外行为。Oracle 已承认了一些与 JRE 版本 6 有关的安全问题。

    Blackboard Learn 无需任何其他浏览器插件。有关浏览器插件、辅助技术和其他支持软件的详细信息,请参阅本部分中的“浏览器支持策略”主题。


    Analytics for Learn 浏览器支持

    Analytics for Learn 中的报告和直观视图均通过 Blackboard 合作伙伴推出的第三方商业智能工具提供,具体来说:Microsoft (Reporting Services) 提供嵌入式报告,Pyramid (Pyramid BI Office) 进行指示板构建。这些产品在浏览器支持方面做出了自己的承诺,因此,下方的详细信息可能会根据合作伙伴做出的产品决策而发生变更。

    Learn 界面内显示的 Analytics for Learn 报告可通过 Learn 支持的所有浏览器进行查看。独立的 Microsoft Reporting Services 报告也可通过 Learn 支持的浏览器进行查看。请访问 Microsoft 网站,详细了解 Microsoft Reporting Services 的浏览器支持

    要查看 Pyramid 指示板,需使用 HTML-5 兼容的浏览器。Microsoft 已经弃用的旧版 Internet Explorer 无法用来查看 Pyramid 报告。要构建 Pyramid 指示板,需使用 NPAPI 兼容的浏览器,因为 Pyramid 构建工具使用 Microsoft Silverlight 插件。Google Chrome 已经停止支持 NPAPI,因此,该浏览器不兼容。Firefox 或 Safari 用户必须安装并配置 Silverlight 插件,才能在其浏览器中使用它。


    配置说明

    • Internet Explorer 仅在标准模式下受支持。
    • 原始 Blackboard Learn 9.1 界面的 Mac OS X 10.8 及更高版本 Java:Java 不再随操作系统安装一起提供,必须在请求应用程序/小程序时由用户下载和安装,这是用户的一次性操作。

    之前版本的客户技术发生了变化

    • 不再提供对 Internet Explorer 10 的支持。
    • 对浏览器类型和版本的支持定义进行了扩展,从而加入了其他操作系统和格式(包括移动设备和平板电脑设备)。

    技术不受支持

    • Windows XP
    • Windows、Mac OS 和 Linux 系统不运行支持的浏览器
    • 不再受 Microsoft 支持的 Internet Explorer 10 及更低版本;移动设备上的 Internet Explorer
    • 桌面设备上的 Firefox 30 及更低版本;移动设备上的所有 Firefox 版本
    • Chrome 35 及更低版本(移动设备上的 34 及更低版本)
    • Safari 5 及更低版本
    • Blackboard Learn 原始用户界面的 JRE 5

    支持带来原始体验的界面

    本部分仅适用于 Blackboard Learn SaaS 用户。

    Blackboard Learn SaaS 部署中的有些用户界面尚未更新到 Ultra 体验。这些界面包括但不限于以下区域:

    • 原始课程视图 - 使用 Blackboard Learn 9.1 原始课程视图
    • 管理员配置区域
    • 资源库
    • 企业调查
    • 目的管理器
    • Outcomes Assessment 功能

    虽然用户可能已成功在平板电脑和手持设备上使用这些原始体验界面,但此类设备不支持这些界面。