Tarayıcı Desteği

Blackboard Learn, çalışabileceğiniz, ödevleri ve diğer kurs çalışmalarını gönderebileceğiniz tarayıcı tabanlı bir uygulamadır. Web tarayıcınız ile kurumunuzun Learn sürümünün uyumlu olup olmadığını belirlemek için bu kaynakları kullanın.

Ekran okuyucunuzu kullanırken Blackboard Learn'de en iyi deneyimi elde etmek için Windows® sisteminde Firefox® ve JAWS® kullanın. Mac® üzerinde ise Safari® ve VoiceOver kullanın. Blackboard'un erişilebilirlik yazılımı yaklaşımına ilişkin daha fazla bilgi edinmek için Erişilebilirlik konusuna bakın.

Desteklenen tarayıcılar

Blackboard'un genel tarayıcı desteği ilkesi hakkında daha fazla bilgi almak, ayrıca JavaScript, tanımlama bilgileri ve diğer yazılımlar hakkında bilgi bulmak için Tarayıcı Destek İlkesi konusuna bakın. Kurslarınız Orijinal veya Ultra Kurs Görünümü'nde sunulabilir. Tarayıcınız kurs görünümünüzü destekliyor mu öğrenmek için aşağıdaki tablolara bakın.

Google Chrome 42 ve daha yeni sürümleri, Mozilla Firefox 52 ve daha yeni sürümleri ile Microsoft Edge, NPAPI türü eklentileri (Java eklentileri ve pek çok medya tarayıcı eklentisi dahil) desteklemez. Blackboard, bu tarayıcıların kullanımını aşağıdaki durumlarda desteklemez: 1) Görüntüleme için üçüncü parti NPAPI eklentileri gerektiren katıştırılmış medya türlerinde ve 2) İçerik Koleksiyonu'nda bulunan birden çok dosya yükleme arayüzünde. Ancak diğer çoklu dosya yükleme arayüzleri bu tarayıcılarda desteklenmektedir.

Desteklenen Tarayıcılar
 Masaüstü Tarayıcı SürümleriMobil Tarayıcı Sürümleri*
Chrome49 ve daha yeni sürümleri49 ve daha yeni sürümleri
Edge20+20+
Firefox48 ve daha yeni sürümleri48 ve daha yeni sürümleri
Internet Explorer11 ve daha yeni sürümleriDesteklenmiyor
Safari9 ve daha yeni sürümleriiOS 7 ve daha yeni sürümleri

* Mobil tarayıcılar Blackboard Learn 9.1 sürümünde Learn 2016 temasıyla desteklenir. Mobil tarayıcılar ayrıca Orijinal deneyimde desteklenir. Bazı kullanıcılar kullanmayı başarsa da daha eski temalar şu anda bu tarayıcılarda desteklenmemektedir.

Blackboard Uygulaması, Blackboard Instructor ve Bb Grader, Blackboard Learn 9.1 sunucularıyla etkileşim kurabilen mobil cihazlar ve tabletlerde desteklenen yerel uygulamalardır. Bu uygulamaların kendi cihaz gereksinimleri olabilir. 

ULTRA: Desteklenen tarayıcılar

Desteklenen Tarayıcılar
 Masaüstü Tarayıcı SürümleriMobil ve Tablet Tarayıcı Sürümleri
Android TarayıcıMevcut değil4+
Chrome49 ve daha yeni sürümleri49 ve daha yeni sürümleri
Edge20+20+
Firefox48 ve daha yeni sürümleriDesteklenmiyor
Internet ExplorerDesteklenmiyorDesteklenmiyor
Safari9 ve daha yeni sürümleri9 ve daha yeni sürümleri

Test edilen cihazlar ve işletim sistemleri

Desteklenen tarayıcıları test etmek için çok çeşitli cihazlar ve işletim sistemleri kullanılmıştır. Destek sadece bu işletim sistemleriyle sınırlı değildir. Yukarıdaki masaüstü tarayıcı sürümleri çalıştırılacakları cihaz veya işletim sistemi ne olursa olsun desteklenir.

Test için kullanılan cihazlar
KategoriTest Edilen
İşletim SistemleriWindows 7, Windows 8, Windows 10, Mac OS 10.8, Mac OS 10.9, Mac OS 10.10, iOS, Android, Windows Mobile, Chrome OS
iOS CihazlarıiPod Touch, iPhone 4S, iPhone 5S, iPhone5c, iPhone 6, iPad 2, iPad 3, iPad Mini 3, iPad Air 2
Android CihazlarıGalaxy S4, Galaxy S5, HTC G1, LG C800 myTouch, HTC One, Galaxy Note 2014, HTC One M8
Windows Mobile CihazlarıVenue 8 Pro, Lumia 520, Lumia 930
Chrome OS CihazlarıChromebook (Chrome tarayıcısı; NPAPI eklentilerini gerektiren özellikler desteklenmez)

Blackboard, tüm ürünlerini mümkün olduğunca erişilebilir kılmak için çalışmaktadır. JAWS'ın en yeni iki sürümü, tüm Blackboard Learn sürümlerinin erişilebilirlik testinde kullanılır.

Java ve diğer tarayıcı eklentileri

Blackboard Learn'deki birkaç özellik ek yazılım yüklenmesini gerektirir. Bunlar olmadan özellikler çalışmaz. Aşağıdaki Blackboard Learn özellikleri eklenti gerektirir:

  • Kurs Dosyaları'na ve Content Collection'a birden fazla dosya yükleme işlemi, tarayıcı eklentisi olarak Oracle Java Runtime Environment (JRE) öğesinin etkinleştirilmesini gerektirir. Tek dosya yükleme aracı bunu gerektirmez. Karşıya yükleme uygulaması Blackboard tarafından imzalanır ve sertifika sona erse bile uygulamanın çalışmasına izin veren bir zaman damgası yetkisi içerir.
  • Building Block aracılığıyla kullanılan Kurs Odası ve Blackboard Collaborate senkronize iletişim özellikleri, Blackboard Collaborate Başlatıcısı'nın indirilip yüklenmesini gerektirir ancak Java JRE tarayıcı eklentisini gerektirmez.

    Başlatıcı, yalnızca Blackboard Collaborate Orijinal deneyiminde gereklidir. Blackboard Collaborate Ultra deneyimi herhangi bir indirme gerektirmez.

JRE sürüm 7 ve 8, ona bağlı özellikler için önerilen sürümlerdir. JRE sürüm 6 çalışabilir, ancak beklenmedik davranışlarla sonuçlanabilir. Oracle JRE sürüm 6'da bazı güvenlik sorunları olduğunu kabul etmiştir.

Blackboard Learn başka tarayıcı eklentisi gerektirmez. Tarayıcı eklentileri, yardımcı teknoloji ve diğer destek yazılımı hakkında daha fazla bilgi için bu bölümdeki Tarayıcı Desteği İlkesi konusuna bakın.


Analytics for Learn tarayıcı desteği

Analytics for Learn'de kullanılabilen raporlar ve görselleştirmeler Blackboard iş ortaklarının üçüncü taraf iş zekası araçlarıyla, özellikle de katıştırılmış raporlar için Microsoft (Raporlama Hizmetleri) ve pano oluşturma için Pyramid (Pyramid BI Office) ile sunulur. Bu ürünlerin tarayıcı desteği konusunda kendi taahhütleri vardır, dolayısıyla aşağıdaki ayrıntılar iş ortaklarımızın ürünle ilgili verdiği kararlara bağlı olarak değişebilir.

Analytics for Learn, Learn arayüzünde görüntülemenin Learn ile aynı tarayıcılarda desteklendiğini bildirmektedir. Bağımsız Microsoft Raporlama Hizmetleri raporları da Learn ile aynı tarayıcılarda desteklenmektedir. Microsoft Raporlama Hizmetlerine yönelik tarayıcı desteğiyle ilgili daha fazla bilgi için Microsoft web sitesine bakın.

Pyramid panolarını görüntülemek için HTML-5 ile uyumlu bir tarayıcı gerekir. Internet Explorer'ın Microsoft tarafından artık kullanımdan kaldırılan eski sürümleri Pyramid raporlarını görüntülemek için uyumlu değildir. Pyramid oluşturucuda Microsoft Silverlight eklentisi kullanıldığı için sadece NPAPI ile uyumlu tarayıcılarda Pyramid panoları oluşturabilirsiniz. NPAPI desteğini kaldırdığı için Google Chrome'da Pyramid panoları oluşturulamaz. Firefox ve Safari kullanıcılarının Silverlight eklentisini tarayıcılarında kullanabilmek için söz konusu eklentiyi yükleyip yapılandırmaları gerekir.


Yapılandırma notları

  • Orijinal deneyimde Internet Explorer sadece Standart Mod'da desteklenmektedir.
  • Mac OS X 10.8 ve daha yeni sürümlerde Orijinal Blackboard Learn 9.1 arayüzleri için Java: Java artık işletim sistemi yüklemesinin bir parçası olarak sağlanmamakta, uygulamayı kullananlar tarafından indirilip yüklenmesi gerekmektedir. Bu işlem kullanıcı tarafından bir defa yapılır.

İstemci teknolojisinde önceki sürümlere göre farklar

  • Internet Explorer 10 desteği sona ermiştir.
  • Tarayıcı türleri ve sürümlerine göre destek kapsamının genişletilmesine ek işletim sistemleri ve mobil/tablet cihazlar gibi biçimler de dahildir.

Desteklenmeyen teknolojiler

  • Windows XP
  • Desteklenen bir tarayıcıda çalışmayan Windows, Mac OS ve Linux sistemleri
  • Internet Explorer'ın artık Microsoft tarafından desteklenmeyen 10 ve daha önceki sürümleri; mobil cihazlarda Internet Explorer
  • Masaüstünde Firefox'un 30 ve daha önceki sürümleri; mobil cihazlarda tüm Firefox sürümleri
  • Chrome'un 35 ve daha önceki sürümleri (mobil cihazlarda sürüm 34 ve daha önceki sürümler)
  • Safari'nin 5 ve daha önceki sürümleri
  • Blackboard Learn Original için JRE 5 kullanıcı arayüzleri

Orijinal Deneyimde arayüz desteği

Bu bölüm sadece Blackboard Learn SaaS kullanıcıları içindir.

SaaS dağıtımında Blackboard Learn için bazı kullanıcı arayüzleri henüz Ultra deneyim için güncelleştirilmemiştir. Bu arayüzlere aşağıdakiler dahildir, ancak tümü bunlarla sınırlı değildir:

  • Orijinal Kurs Görünümü Blackboard Learn 9.1 Orijinal Kurs Görünümü kullanılıyor
  • Yönetici yapılandırma alanları
  • İçerik Koleksiyonu
  • Kuruluş ölçme sınavları
  • Hedefler yöneticisi
  • Sonuç Değerlendirme özellikleri

Bu Orijinal deneyim arayüzleri tabletlerde ve avuç içi cihazlarında desteklenmez, ancak yine de kullanıcılar bunları bu cihazlarda belirli oranda başarıyla kullanabilirler.