Поддержка обозревателей

Blackboard Learn — это приложение, которое работает в веб-обозревателе и позволяет выполнять и отправлять задания и другие работы по программе курса. Данные ресурсы помогут определить, совместим ли ваш браузер с версией Learn вашего учреждения.

Для работы с программой чтения с экрана в Blackboard Learn на компьютере с ОС Windows® рекомендуется использовать браузер Firefox® и программу Jaws®. На компьютере Mac® используйте браузер Safari® и программу VoiceOver. В теме «Специальные возможности» можно узнать больше о подходе Blackboard к программному обеспечению с поддержкой специальных возможностей.

Поддерживаемые браузеры

Дополнительные сведения о политике Blackboard относительно поддержки обозревателей, а также о JavaScript, файлах cookie и другом программном обеспечении см. в главе «Политика поддержки обозревателей». Ваши курсы могут отображаться в традиционном представлении или в представлении Ultra. Сверьтесь с таблицей ниже, чтобы определить, поддерживает ли ваш браузер представление вашего курса.

Google Chrome версии 42 и новее, а также браузеры Mozilla Firefox (52 или новее) и Microsoft Edge не поддерживают подключаемые модули типа NPAPI, в том числе подключаемые модули Java и ряд подключаемых модулей мультимедиа. Blackboard не поддерживает использование этих браузеров при таких обстоятельствах: 1) со встроенными файлами мультимедиа, для просмотра которых требуются подключаемые сторонние модули NPAPI, и 2) с интерфейсом Content Collection для отправки нескольких файлов, хотя другие интерфейсы отправки нескольких файлов поддерживаются в этих браузерах.

Поддерживаемые обозреватели
 Версии браузеров для настольных компьютеровВерсии браузеров для мобильных устройств*
Chrome49 и новее49 и новее
Edge20 и новее20 и новее
Firefox48 и новее48 и новее
Internet Explorer11 и новееНе поддерживается
Safari9 и новеес iOS 7 и новее

* Мобильные браузеры поддерживаются в Blackboard Learn 9.1 с темой Learn 2016. Мобильные браузеры также поддерживаются в традиционном интерфейсе. В настоящее время более ранние темы в этих браузерах не поддерживаются , хотя у пользователей они могут работать.

Приложение Blackboard, Blackboard Instructor и Bb Grader — поддерживаемые собственные приложения для мобильных телефонов и планшетов, которые взаимодействуют с серверами Blackboard Learn 9.1. Эти приложения могут иметь собственные требования к устройствам. 

ULTRA. Поддерживаемые браузеры

Поддерживаемые обозреватели
 Версии браузеров для настольных компьютеровВерсии браузеров для мобильных телефонов и планшетов
Обозреватели AndroidНет данных4 и новее
Chrome49 и новее49 и новее
Edge20 и новее20 и новее
Firefox48 и новееНе поддерживается
Internet ExplorerНе поддерживаетсяНе поддерживается
Safari9 и новее9 и новее

Протестированные устройства и операционные системы

Работа поддерживаемых обозревателей протестирована на ряде устройств и операционных систем. Поддержка не ограничивается исключительно этими операционными системами. Приведенные выше версии обозревателей для настольных компьютеров поддерживаются вне зависимости от устройства или операционной системы, в которой они запущены.

Устройства, использованные при тестировании
КатегорияПротестированные
Операционные системыWindows 7, Windows 8, Windows 10, Mac OS 10.8, Mac OS 10.9, Mac OS 10.10, iOS, Android, Windows Mobile, Chrome OS
Устройства с iOSiPod Touch, iPhone 4S, iPhone 5S, iPhone 5c, iPhone 6, iPad 2, iPad 3, iPad Mini 3, iPad Air 2
Устройства с AndroidGalaxy S4, Galaxy S5, HTC G1, LG C800 myTouch, HTC One, Galaxy Note 2014, HTC One M8
Устройства с Windows MobileVenue 8 Pro, Lumia 520, Lumia 930
Устройства с Chrome OSChromebook (обозреватель Chrome; не поддерживаются функции, для которых требуются подключаемые модули NPAPI)

Компания Blackboard стремится сделать все свои продукты максимально доступными. Две последние доступные версии JAWS используются при тестировании специальных возможностей каждой версии Blackboard Learn.

Java и другие подключаемые модули для бразуера

Для некоторых функций Blackboard Learn требуется установка дополнительного программного обеспечения. Без него работа этих функций невозможна. Ниже перечислены функции Blackboard Learn, для которых требуются подключаемые модули.

  • Для отправки нескольких файлов курса и функции Content Collection необходимо установить Java Runtime Environment (JRE) от корпорации Oracle в качестве подключаемого модуля для браузера. Для отправки отдельных файлов этот компонент не требуется. Приложение для отправки имеет цифровую подпись Blackboard и может добавлять метки времени, что позволяет работать с ним, даже если срок действия сертификата истек.
  • Для функций синхронной передачи «Аудитория для курса» и Blackboard Collaborate, работающих с помощью модуля Building Block, необходимо загрузить и установить средство Blackboard Collaborate Launcher, но подключаемый модуль для браузера JRE не требуется.

    Средство запуска требуется только для Blackboard Collaborate с традиционным интерфейсом. Для Blackboard Collaborate с интерфейсом Ultra никаких загрузок не требуется.

Если для функции требуется среда Java, рекомендуем использовать среду JRE версий 7 и 8. Среда JRE версии 6, возможно, будет работать, однако использование этой версии может привести к неожиданным неполадкам. Корпорация Oracle признала наличие некоторых проблем безопасности в 6-й версии JRE.

Blackboard Learn не требует других подключаемых модулей для браузера. Дополнительные сведения о подключаемых модулях для браузера, специальных возможностях и других вспомогательных программах см. в главе «Политика поддержки веб-обозревателей» этого раздела.


Модуль Analytics для поддержки обозревателей в среде Learn

Отчеты и визуальные представления в модуле Analytics для среды Learn предоставляются партнерами Blackboard, использующими сторонние средства бизнес-аналитики, в частности корпорацией Майкрософт (Reporting Services) для встроенных отчетов и Pyramid (Pyramid BI Office) для построения панелей мониторинга. На эти продукты распространяются отдельные политики поддержки обозревателей, поэтому приведенные ниже сведения могут измениться в зависимости от решений, которые наши партнеры принимают в отношении своих продуктов.

Отчеты модуля Analytics для среды Learn, отображающиеся в интерфейсе Learn, поддерживаются в тех же обозревателях, что и сама среда Learn. Автономные отчеты Microsoft Reporting Services также поддерживаются в тех же обозревателях, что и среда Learn. Дополнительные сведения о поддержке обозревателей службами Microsoft Reporting Services см. на веб-сайте корпорации Майкрософт.

Для просмотра панелей мониторинга Pyramid требуется обозреватель, совместимый с HTML-5. Более ранние версии Internet Explorer, которые уже не поддерживает корпорация Майкрософт, не позволяют просматривать отчеты Pyramid. Для построения панелей мониторинга Pyramid требуется браузер с поддержкой NPAPI, так как конструктор Pyramid использует подключаемый модуль Microsoft Silverlight. Google Chrome не поддерживает подключаемые модули NPAPI, поэтому этот обозреватель является несовместимым. Пользователи Firefox и Safari должны установить и настроить подключаемый модуль Silverlight, чтобы использовать его в браузере.


Примечания по конфигурации

  • Internet Explorer поддерживается только в режиме стандартов в традиционном интерфейсе.
  • Java в Mac OS X 10.8 и новее для традиционных интерфейсов Blackboard Learn 9.1: Java больше не поставляется в составе этих операционных систем и устанавливается пользователям по запросу приложения или аплета. Это действие требуется выполнить только один раз.

Изменения клиентской технологии по сравнению с предыдущими версиями

  • Прекращена поддержка Internet Explorer 10.
  • Расширено определение поддержки по типам и версиям обозревателей, чтобы включить дополнительные операционные системы и форматы, в том числе мобильные телефоны и планшеты.

Неподдерживаемые технологии

  • Windows XP
  • Системы Windows, Mac OS и Linux с неподдерживаемым обозревателем
  • Internet Explorer 10 и более ранние версии, которые больше не поддерживаются корпорацией Майкрософт; Internet Explorer на мобильных устройствах
  • Firefox 30 и более ранние версии на настольных системах; все версии Firefox на мобильных устройствах
  • Chrome 35 и более ранние версии (34 и более ранние версии на мобильных устройствах)
  • Safari 5 и более ранние версии
  • JRE 5 для традиционных интерфейсов Blackboard Learn

Поддержка традиционных интерфейсов

Данный раздел относится только к пользователям Blackboard Learn SaaS.

Некоторые пользовательские интерфейсы Blackboard Learn с развертыванием на основе SaaS еще не обновлены до версии Ultra. Это касается перечисленных ниже случаев (но не ограничивается ими).

  • Традиционное представление курса — использование традиционного представления курса в Blackboard Learn 9.1
  • Администраторская конфигурация
  • Content Collection
  • Опросы Enterprise
  • Диспетчер целей
  • Функции оценки Outcomes

Эти традиционные интерфейсы не поддерживаются на мобильных устройствах, хотя пользователям может удаться использовать их.