En cada lanzamiento, Blackboard dedica tiempo y recursos a ejecutar Blackboard Learn en los sistemas operativos, las bases de datos y los navegadores disponibles más recientes, con el objetivo de crear un sistema que sea más estable, más fácil de usar y que se pueda administrar mejor.

En este tema, se destacan los cambios principales en los navegadores y las tecnologías compatibles para esta versión. 

Para definir con mayor claridad las declaraciones de compatibilidad en relación con las tecnologías de clientes de terceros, Blackboard ya no clasifica la compatibilidad con las tecnologías con los términos "admitida" ni "certificada". Estas tecnologías ahora se clasifican como completamente compatibles o no compatibles. Se intenta que las tecnologías con o sin asistencia se alineen en la medida de lo posible con las directivas de asistencia de proveedores de terceros.

  • Compatible: compatible con el proveedor y con Blackboard.
  • No compatible: no compatible con el proveedor ni con Blackboard.

Configuraciones del servidor de 64 bits

Sistemas operativos y bases de datos compatibles
 Servidor de aplicaciones OpenJDK 11 Corretto3SQL Server 20171SQL Server 20191Oracle 19c1,2Oracle 18cOracle 12cR21,2,4
Windows Server 2016CompatibleCompatibleNo compatibleNo compatibleNo compatibleNo compatible
Windows Server 20194CompatibleNo compatibleCompatibleNo compatibleNo compatibleNo compatible
Red Hat Enterprise Linux Server 7.x3CompatibleNo compatibleNo compatibleCompatibleNo compatibleCompatible

1. Las configuraciones de Server AlwaysOn para SQL Server y RAC para Oracle no son oficialmente compatibles. La declaración de compatibilidad es la siguiente: "Blackboard recomienda encarecidamente que, a efectos de la administración del sistema, Blackboard Learn se instale en una base de datos de una sola instancia. Oracle RAC y Microsoft SQL Server AlwaysOn tienen configuraciones de alta disponibilidad de sus proveedores respectivos. Si las políticas institucionales le exigen ejecutar Blackboard Learn en un entorno de base de datos de AlwaysOn o RAC, puede hacerlo, pero tenga en cuenta que Blackboard Learn solo respalda la instalación en la capa JDBC de Learn a base de datos, no en la capa de base de datos. Los problemas que surjan en la capa de JDBC se aceptarán como incidentes de compatibilidad, y se tratarán y resolverán según los procedimientos estándar del área de soporte de productos. Los demás problemas que surjan en la capa de la base de datos deberán consultarse con el proveedor de la base de datos. Si no puede resolver los problemas de la base de datos en la capa de la base de datos en estas configuraciones, el área de soporte de productos le recomendará cambiar a una configuración de base de datos de instancia única para obtener asistencia continua".

2. Oracle ASO (configuración de seguridad avanzada) no es compatible.

3. Se presupone que las pruebas de lanzamiento utilizarán la última versión de mantenimiento de estas tecnologías. Es decir, la versión más reciente de Corretto 11 y RHEL 7.9.

4. Oracle 12cR2 es un lanzamiento de canal estable que deja de ser compatible durante el período de compatibilidad de esta versión. Si se continúa utilizando después de ese período, se requerirá un acuerdo de compatibilidad extendida por parte de Oracle. Para Windows Server, se recomienda una versión de canal de servicio a largo plazo.

Configuraciones del servidor de 32 bits

Las configuraciones de 32 bits no son compatibles.


Notas sobre la configuración

Consulte los navegadores compatibles con Blackboard Learn 9.1 3900.0

Nota: Todas las configuraciones compatibles se basan en la versión secundaria más reciente del software compatible, incluidos los Service Packs de Microsoft y los parches de Oracle (DB y Java). RHEL 7.9 debería probarse como la versión actual disponible, pero las versiones de RHEL 7 admitidas de forma activa por Red Hat también deben considerarse compatibles con esta versión.

Declaración sobre la compatibilidad con Oracle RAC

Versión de OracleCompatible con RAC
11gR2No compatible
12cR2provisorio

Declaración de compatibilidad de virtualización

VMWare ESX Server 4.1Comentarios
Certificado

Palabras textuales de las notas de la versión 9.1:
VMware® ESX Server 4 (Linux® y Windows®) es la única configuración que cuenta con la certificación de Blackboard para la versión 9.1.

Blackboard admite otras soluciones de virtualización, siempre que Blackboard y el hipervisor sean compatibles con el sistema operativo guest.

Además de VMware, Blackboard también tiene experiencia con Citrix XenServer 5.5, Solaris 10 Zones y Red Hat® Enterprise Linux® 4 y 5 Xen™.

No compatible

  • Java 8
  • Oracle 18c
  • Oracle 12cR2

Rutas de actualización compatibles

El departamento de Desarrollo de productos de Blackboard certifica las actualizaciones directamente desde dos lanzamientos anteriores: