Si viene de otro sistema de gestión de aprendizaje (LMS), puede utilizar el bloque Conversor del curso para migrar el contenido de su curso.

Sistemas LMS compatibles

  • Blackboard (versiones 6, 7, 8, 9 y 9.1)
  • ANGEL (versiones 7.2, 7.3 y 7.4)
  • Desire2Learn
  • WebCT (versiones 4 y 6)

Descripción general de los pasos para convertir contenido

  1. Agregue el bloque Conversor del curso a su sitio.
  2. Suba un archivo desde el LMS al conversor del curso.
  3. Convierta el archivo para su sitio. La conversión crea el formato 1.9.
  4. Convierta el archivo de 1.9 a 2.0.

Conversor de cursos

Agregue el bloque Conversor de cursos

  1. En la página de inicio del sitio, seleccione Activar edición.
  2. En el menú Agregar un block, seleccione Conversor del curso. El block Conversor del curso está disponible en el sitio.

Si no visualiza el block Conversor del curso en el menú Agregar un block, deberá instalarlo o mostrarlo. En Administración del sitio, seleccione Extensiones, Bloques y Gestionar bloques.


Subir sus archivos de LMS

  1. Desde el bloque Conversor del curso, seleccione Gestionar archivos.
  2. En el área Subir un archivo para conversión, seleccione Elegir un archivo para buscar un Archivo para subir.

    También puede arrastrar y soltar los archivos en el cuadro Archivo para subir.

  3. En Subir un archivo, seleccione Elegir archivo, seleccione la ubicación del archivo y seleccione Subir este archivo.
  4. Seleccione Guardar cambios. Los archivos se suben y aparecen en el área Archivos subidos, en orden alfabético.

Convertir el archivo LMS al formato Moodle 1.9

Una vez que haya subido los archivos LMS de copia de seguridad del curso, puede convertir las copias de seguridad del curso LMS a copias de seguridad de Moodle 1.9 mediante la pestaña Convertir.

  1. Desde el bloque Conversor del curso, seleccione Convertir.
  2. Seleccione el LMS utilizado para los archivos del menú Conversor.
  3. Seleccione el formato de curso Moodle 1.9 para convertir en el menú Formato. Según el Conversor seleccionado, las opciones incluyen el formato de la vista de carpetas, el formato de la vista semanal o el formato de la vista por temas.
  4. Seleccione los archivos LMS de copia de seguridad del curso que convertirá.

    En el caso de clientes que estén subiendo archivos de varios sistemas LMS o diferentes versiones de un LMS, asegúrese de que los archivos LMS de copia de seguridad del curso del tengan un nombre que identifique al LMS y a la versión. La pestaña Convertir solo permite la selección de un LMS y una versión para convertir por vez, y la herramienta intentará convertir cualquier archivo seleccionado, incluso si pertenece a un LMS diferente o a una versión incompatible.

  5. Una vez que haya respondido todas las preguntas sobre la conversión, haga clic en Convertir. Comienza el proceso de conversión. Observe el progreso de conversión de cada archivo en la pantalla.

Una vez que convierta el contenido de LMS a Moodle 1.9, deberá convertir el formato 1.9 a 2.0. 

La pestaña Gestionar archivos convertidos permite al administrador del sitio gestionar todos los archivos de copia de seguridad del curso de Moodle 1.9 que se han convertido. Desde aquí puede eliminar y restaurar cualquier archivo LMS convertido.


Convertir Moodle 1.9 a 2.0

De la versión 2.3 en adelante, todos los archivos de copia de seguridad de la versión 1.9 sin datos de usuario pueden convertirse directamente desde el área Restaurar curso. La función Convertir las copias de seguridad de la versión 1.9 a la versión 2.0 es útil para los clientes que actualizan la versión 1.9 o para aquellos en proceso de cambio desde otro sistema de gestión del aprendizaje (LMS) que convirtieron todos sus cursos mediante el bloque Conversor de cursos o con Blackboard Open LMS. Esta función solicita la conversión de uno o más cursos de la versión 1.9. Un proceso interno toma los cursos y los restaura en un sitio de la versión 1.9, actualiza el sitio de la versión 1.9 a 2.0 y, luego, realiza una copia de seguridad de dichos cursos. Luego, los archivos de copia de seguridad de la versión 2.0 se colocan nuevamente en el sitio del cliente para su restauración o descarga.

Blackboard recomienda que los clientes con diversos cursos se conviertan, y que los cursos de la versión 1.9 que incluyen datos de usuario en sus archivos de copia de seguridad usen los procesos en esta página. Si solo hay algunos cursos para convertir y estos no incluyen datos de usuario, es más rápido convertirlos directamente en el área Restaurar de un curso.


Descripción general del proceso

Estos pasos describen cómo funciona el proceso.

  1. El administrador del sitio sube los archivos de copia de seguridad de cursos de la versión 1.9.
  2. El administrador del sitio solicita que los archivos de copia de seguridad de cursos de la versión 1.9 se conviertan a la versión 2.0.
  3. La solicitud se añade a la cola de conversión.
  4. Se procesan las solicitudes más altas en la cola.
  5. La solicitud alcanza la parte superior de la cola y se pone en marcha el proceso de conversión.
  6. Se crea el sitio de la versión 1.9 temporal.
  7. Se copian los archivos de copia de seguridad solicitados en el sitio de la versión 1.9 temporal.
  8. Los archivos de copia de seguridad de la versión 1.9 se restauran en el sitio de la versión 1.9 temporal.
  9. El sitio de la versión 1.9 temporal se actualiza al sitio de la versión 2.0 temporal.
  10. Se realiza la copia de seguridad de todos los cursos en el sitio de la versión 2.0 temporal.
  11. Todos los archivos de copia de seguridad se mueven al directorio moodledata/moodle19to20/converted del sitio del cliente.
  12. Se envía un correo electrónico al cliente en el que se le notifica que la conversión está completa.

Acceder a la utilidad Convertir las copias de seguridad de la versión 1.9 a la versión 2.0

  • Acceda a la función Convertir las copias de seguridad de la versión 1.9 a la versión 2.0 desde el bloque Administración.

    En el bloque Administración, haga clic en Administración del sitio, luego en Blackboard Open LMS y, finalmente, en Convertir las copias de seguridad de la versión 1.9 a la versión 2.0.

La función Convertir las copias de seguridad de la versión 1.9 a la versión 2.0 está separada en tres pestañas:

  • Copias de seguridad de la versión 1.9 (listas): Contiene todos los archivos de copia de seguridad de cursos de la versión 1.9 no procesados y permite que el administrador de un sitio suba archivos nuevos. Son las copias de seguridad de cursos disponibles para convertir. Esta pestaña coincide con el directorio moodle19to20/ready que está en el directorio moodledata del sitio. En esta pestaña también se muestra la cantidad de almacenamiento usado durante el proceso de conversión.
  • Copias de seguridad de la versión 2.0 (convertidas): Contiene todas las copias de seguridad de cursos de la versión 2.0 creadas mediante el proceso de conversión. Esta pestaña coincide con el directorio moodle19to20/converted que está en el directorio moodledata del sitio. En esta pestaña también se muestra la cantidad de almacenamiento usado por los archivos de copia de seguridad de cursos en cada uno de los directorios.
  • Archivo de las copias de seguridad de la versión 1.9 (archivados): Contiene todos los archivos de copia de seguridad de cursos de la versión 1.9 que se convertieron. Esta pestaña coincide con el directorio moodle19to20/archived que está en el directorio moodledata del sitio.

Subir y convertir de la versión 1.9 a la versión 2.0

Si utilizaba otro sistema de gestión del aprendizaje (LMS) y convirtió todos los cursos con el bloque Conversor de cursos o mediante los servicios de Blackboard Open LMS, dichos cursos se convirtieron a una copia de seguridad de la versión 1.9 de Moodle. El paso siguiente es convertir esos archivos a un formato 2.0 con la Función de copias de seguridad 1.9 a 2.0.

Blackboard le recomienda que suba los archivos manualmente cuando solo tiene un par de archivos atípicos para migración. También le recomienda que use SFTP si necesita migrar varios archivos o archivos particularmente grandes.

Subir y convertir los archivos en forma manual

Pasos: Administración > Administración del sitio > Blackboard Open LMS > Convertir las copias de seguridad de la versión 1.9 a la versión 2.0

  1. En Administración del sitio, seleccione Blackboard Open LMS y Convertir las copias de seguridad de la versión 1.9 a la versión 2.0.
  2. Subir los archivos:
    • Seleccione Subir archivo de copia de seguridad de Moodle 1.9.
    • Seleccione Elegir un archivo y seleccione un archivo del disco duro o de la red para subir.
    • Seleccione Cargar.
    • Repita los pasos para los archivos adicionales.
  3. Solicitar conversión a una copia de seguridad de la versión 2.0:
    • Marque cada curso que desea migrar. También puede usar la opción Seleccionar todo.
    • Seleccione Enviar solicitud para el procesamiento.
    • Escriba su dirección de correo electrónico en el cuadro Solicitar notificaciones enviadas a.
      Una vez finalizada la migración, recibirá una notificación en esta dirección de correo electrónico.
    • Seleccione Enviar solicitud para el procesamiento.
      Recibirá la notificación de la copia de seguridad en su correo electrónico. También recibirá un correo electrónico del equipo de soporte de Blackboard Open LMS en el que se le indicará que se migraron los archivos.
  4. Para ver las copias de seguridad que se migraron, seleccione la pestaña Copias de seguridad de la versión 2.0 (convertidas).
    Si la migración se realiza satisfactoriamente, los archivos convertidos se mostrarán en la pestaña Copias de seguridad de la versión 2.0 (convertidas) y el archivo de copia de seguridad se eliminará de la pestaña Copias de seguridad de la versión 1.9 (listas) y se detallará en la pestaña Archivo de las copias de seguridad de la versión 1.9 (archivados).

    Tarde o temprano, elimine los archivos de copia de seguridad archivados tras haber sido convertidos para ahorrar espacio en el servidor y dinero.

  5. Copiar los archivos en las copias de seguridad del sitio o restaurarlos:
    • Para copiar los archivos en las copias de seguridad del sitio:
      • Marque los archivos que desea mover. También puede usar la opción Seleccionar todos.
      • En el menú Seleccionar, seleccione Copiar a las copias de seguridad del sitio.
    • Para restaurar los archivos en el sitio:
      • Marque los archivos que desea restaurar. También puede usar la opción Seleccionar todo.
      • Seleccione Restaurar en el menú Seleccionar.
      • En el menú Restaurar en esta categoría, seleccione la categoría en la que se encontrarán los archivos.
      • Seleccione todos los archivos que desea restaurar.
      • Marque Operación no atendida para ejecutar la restauración en forma automática.
      • Seleccione Restaurar ahora.
        El proceso de restauración comienza y puede demorar.
  6. Repita este proceso para los archivos adicionales que desee migrar de una copia de seguridad de la versión 1.9 a la versión 2.0.

Subir copias de seguridad de cursos de la versión 1.9 y subir por lotes en el conversor de la versión 2.0

Pasos: Administración > Administración del sitio > Blackboard Open LMS > Convertir las copias de seguridad de la versión 1.9 a la versión 2.0

  1. En Administración del sitio, seleccione Blackboard Open LMS y Convertir las copias de seguridad de la versión 1.9 a la versión 2.0.
  2. Obtenga la información de inicio de sesión de SFTP para el sitio de la versión 2.0 específico.
    En la página Convertir las copias de seguridad de la versión 1.9 a la versión 2.0 se muestra la información de inicio de sesión de SFTP para el sitio específico de la versión 2.0 de Moodle. El conversor de la versión 2.0 de Moodle muestra el directorio (en la parte inferior) donde colocar los archivos mediante SFTP. Más tarde necesitará esta información de directorio.
  3. Inicie sesión en el cliente SFTP.

    Debe contar con la configuración de Dropbox SFTP para conversión de cursos.

  4. Suba los archivos.
    Suba/Suba en lote todos los archivos de las copias de seguridad de cursos de la versión 1.9 de Moodle en el directorio provisto en el conversor de la versión 2.0, que es su sitio de Moodle de producción o desarrollo. Después de cargar todos los archivos en el directorio, puede “procesar” la conversión de la versión 1.9 a la versión 2.0 de Moodle.
  5. Solicitar conversión a una copia de seguridad de la versión 2.0:
    • Marque cada curso que desea migrar. También puede usar la opción Seleccionar todo.
    • Seleccione Enviar solicitud para el procesamiento.
    • Escriba su dirección de correo electrónico en el cuadro Solicitar notificaciones enviadas a.
      Una vez finalizada la migración, recibirá una notificación en esta dirección de correo electrónico.
    • Seleccione Enviar solicitud para el procesamiento.
      Recibirá la notificación de la copia de seguridad en su correo electrónico. También recibirá un correo electrónico del equipo de soporte de Blackboard Open LMS en el que se le indicará que se migraron los archivos.
  6. Para ver las copias de seguridad que se migraron, seleccione la pestaña Copias de seguridad de la versión 2.0 (convertidas).
    Si la migración se realiza satisfactoriamente, los archivos convertidos se mostrarán en la pestaña Copias de seguridad de la versión 2.0 (convertidas) y el archivo de copia de seguridad se eliminará de la pestaña Copias de seguridad de la versión 1.9 (listas) y se detallará en la pestaña Archivo de las copias de seguridad de la versión 1.9 (archivados).

    Tarde o temprano, elimine los archivos de copia de seguridad archivados tras haber sido convertidos para ahorrar espacio en el servidor y dinero.

  7. Copiar los archivos en las copias de seguridad del sitio o restaurarlos:
    • Para copiar los archivos en las copias de seguridad del sitio:
      • Marque los archivos que desea mover. También puede usar la opción Seleccionar todos.
      • En el menú Seleccionar, seleccione Copiar a las copias de seguridad del sitio.
    • Para restaurar los archivos en el sitio:
      • Marque los archivos que desea restaurar. También puede usar la opción Seleccionar todos.
      • En el menú Seleccionar, seleccione Restaurar.
      • En el menú Restaurar en esta categoría, seleccione la categoría en la que se encontrarán los archivos.
      • Seleccione todos los archivos que desea restaurar.
      • Marque Operación no atendida para ejecutar la restauración en forma automática.
      • Seleccione Restaurar ahora.
        El proceso de restauración comienza y puede demorar.

Configuración de SFTP para los archivos de copia de seguridad de cursos

Los archivos de copia de seguridad de cursos de las versiones 1.9 y 2.0 pueden subirse o descargarse del sitio por lotes o de uno por vez con el programa FTP/SFTP. Los siguientes son algunos programas de SFTP recomendados:

Configurar la conexión SFTP

  1. Primero, conéctese a la cuenta SFTP con la información provista por el representante de Blackboard Open LMS. Inicialmente, usted es ubicado en un directorio de clientes.
  2. Desplácese hasta el directorio /clients/<sitename>/moodle19to20/. Reemplace la cadena <sitename> por el inicio de la URL del sitio provista por Blackboard.
  3. Seleccione uno de los tres directorios que puede usar la utilidad Convertir las copias de seguridad de la versión 1.9 a la versión 2.0 para los datos:
    • Archivados: corresponde a la pestaña Archivo de las copias de seguridad de la versión 1.9 (archivados), donde puede descargar todos los archivos .zip de copia de seguridad de cursos de la versión 1.9 archivados después de ser convertidos.
    • Convertidos: corresponde a la pestaña Copias de seguridad de la versión 2.0 (convertidas), donde puede descargar todos los archivos .zip de copia de seguridad de cursos de la versión 2.0 creados de las copias de seguridad de cursos de la versión 1.9.
    • Listos: corresponde a la pestaña Copias de seguridad de la versión 1.9 (listas), donde puede subir todos los archivos .zip de copia de seguridad de cursos de la versión 1.9. Verá una lista de todos los archivos subidos a través de la interfaz Subir archivo de copia de seguridad 1.9. El archivo que suba se agregará al listado Directorio para el área moodledata/moodle19to20/ready/ de la ficha Copias de seguridad de la versión 1.9 (listas) del sitio.

Mover una copia de seguridad desde el bloque Conversor del curso para convertirla

Pasos: Administración > Administración del sitio > Blackboard Open LMS > Convertir las copias de seguridad de la versión 1.9 a la versión 2.0 > Mover copias de seguridad desde el conversor de cursos

Si convirtió archivos de copia de seguridad de cursos desde otro sistema de gestión del aprendizaje (LMS), puede usar el botón Mover copias de seguridad del conversor de cursos para seleccionar los archivos que desea mover a la función Convertir las copias de seguridad de la versión 1.9 a la versión 2.0.

  1. En Administración del sitio, seleccione Blackboard Open LMS y Convertir las copias de seguridad de la versión 1.9 a la versión 2.0.
  2. Seleccione Mover copias de seguridad del conversor de cursos para ubicar las copias de seguridad de cursos de la versión 1.9 que desea mover desde el bloque Conversor de cursos.
    Este botón no aparece si no tiene el block Conversor del curso agregado a una página del sitio.
  3. Para realizar la conversión, marque cada archivo de copia de seguridad de cursos de la versión 1.9 que desea mover a la utilidad Convertir las copias de seguridad de la versión 1.9 a la versión 2.0.
    Puede usar la opción Seleccionar todos, según sea necesario.
  4. Seleccione Mover archivos
    . El archivo se agrega al listado Directorio para el área moodledata/moodle19to20/ready/ en orden alfabético.

Los archivos del block Conversor del curso son movidos, NO COPIADOS. Le recomendamos que descargue una copia del archivo localmente o que se asegure de tener el archivo de copia de seguridad de cursos de LMS original antes de seleccionar Mover archivos.


Descargar archivos de copia de seguridad

Pasos: Administración > Administración del sitio > Blackboard Open LMS > Convertir las copias de seguridad de la versión 1.9 a la versión 2.0

Puede usar Función de copias de seguridad 1.9 a 2.0 para descargar copias de las copias de seguridad de archivos del curso. Use esta función para tener una copia impresa de los archivos.

  1. En Administración del sitio, seleccione Blackboard Open LMS y Convertir las copias de seguridad de la versión 1.9 a la versión 2.0.
  2. Seleccione el archivo que desee descargar.
    • Descargue los archivos que están listos para ser convertidos a la versión 2.0: Seleccione Descargar en el menú contextual.
    • Descargue los archivos ya convertidos a la versión 2.0: Seleccione Copias de seguridad de la versión 2.0 (convertidas). Seleccione Descargar en el menú contextual.
    • Archivos archivados: Seleccione Archivo de las copias de seguridad de la versión 1.9 (archivados). Seleccione Descargar en el menú contextual.
  3. Seleccione Guardar archivo y seleccione el lugar dónde desea abrir la información.

Eliminar archivos de copia de seguridad

Pasos: Administración > Administración del sitio > Blackboard Open LMS > Convertir las copias de seguridad de la versión 1.9 a la versión 2.0

Puede eliminar todos los archivos del curso que ya no necesite. La eliminación de archivos permite ahorrar espacio de almacenamiento.

  1. En Administración del sitio, seleccione Blackboard Open LMS y Convertir las copias de seguridad de la versión 1.9 a la versión 2.0.
  2. Seleccione los archivos que desee eliminar.
    • Archivos de copia de seguridad de cursos de la versión 1.9: Marque los archivos que desea eliminar. También puede elegir Seleccionar todo. Seleccione Eliminar en el menú contextual de archivos.
    • Archivos de copia de seguridad de cursos de la versión 2,0: Seleccione Copias de seguridad de la versión 2.0 (convertidas). Marque los archivos que desea eliminar. También puede elegir Seleccionar todo. Seleccione Eliminar en el menú contextual de archivos.
    • Archivos archivados: Seleccione Archivo de las copias de seguridad de la versión 1.9 (archivados). Marque los archivos que desea eliminar. También puede elegir Seleccionar todo. Seleccione Eliminar en el menú contextual de archivos.
  3. Seleccione Continuar para confirmar la eliminación.

    La información se eliminará del directorio.


Mover archivos de copia de seguridad archivados a listos

Pasos: Administración > Administración del sitio > Blackboard Open LMS > Convertir las copias de seguridad de la versión 1.9 a la versión 2.0

En caso de ser necesario, puede mover los archivos archivados nuevamente al estado de listos para la conversión.

  1. En Administración del sitio, seleccione Blackboard Open LMS y Convertir las copias de seguridad de la versión 1.9 a la versión 2.0.
  2. Seleccione la pestaña Archivo de las copias de seguridad de la versión 1.9 (archivados).
  3. Marque los archivos que desea mover.

    También puede seleccionar Seleccionar todo.

  4. Seleccione Mover a listos en el menú.

    Volverá a la ficha Archivo de las copias de seguridad de la versión 1.9 (archivados), donde se moverán los archivos.