دعم المستعرض

في هذه الصفحة

    دعم المستعرض

    إن Blackboard Learn عبارة تطبيق قائم على المستعرضات حيث يمكنك العمل وإرسال الواجبات والأعمال الأخرى الخاصة بالمقرر الدراسي. استخدم هذه الموارد لتحديد ما إذا كان مستعرض الويب متوافقًا مع إصدار المؤسسة من تطبيق Learn.

    للحصول على أفضل تجربة في Blackboard Learn مع قارئ الشاشة، استخدم Firefox®‎ وJAWS®‎ في نظام Windows®‎. استخدم Safari®‎ وVoiceOver في Mac®‎. راجع موضوع "وصول ذوي الاحتياجات الخاصة" للتعرف على مزيد من المعلومات الخاصة بنهج Blackboard في التعامل مع البرامج التي تسهل وصول ذوي الاحتياجات الخاصة.

    المستعرضات المدعومة

    لمعرفة المزيد من المعلومات حول السياسة العامة لدعم المستعرض في Blackboard وكذلك العثور على المعلومات الخاصة بـ Javascript وملفات تعريف الارتباط والبرامج الأخرى، يُرجى مراجعة موضوع سياسة دعم المستعرض.

    المستعرضات المعتمدة
     إصدارات مستعرضات أنظمة تشغيل سطح المكتبإصدارات مستعرضات أنظمة تشغيل الأجهزة الجوالة والأجهزة اللوحية*
    مستعرض Androidغير متاح‎4+‎
    Chrome**‎‎36+‎35+‎
    Edge**‎‎20+‎20+
    Firefox**‎‎31+‎غير معتمد
    Internet Explorer***‎+11غير معتمد
    مستعرض Safari‎6+‎‎6+‎

    * إن إصدارات الأجهزة الجوالة من هذه المستعرضات غير مدعومة لاستخدام تطبيق Blackboard Learn 9.1 حاليًا، وذلك على الرغم من احتمالية نجاح المستخدمين في تشغيلها. يتوافق Blackboard Learn مع الواجهة Ultra مع هذه المستعرضات  في الأجهزة المحمولة والأجهزة اللوحية.

    ** لا يدعم الإصدار 42 فأعلى من Google Chrome والإصدار 52 فأعلى من Mozilla Firefox وMicrosoft Edge المكونات الإضافية من نوع NPAPI، بما في ذلك مكونات Java الإضافية والعديد من المكونات الإضافية الخاصة بمستعرضات الوسائط. لا تدعم Blackboard هذه المستعرضات للاستخدام في الحالات التالية: 1) مع أنواع الوسائط المضمنة التي تتطلب المكونات الإضافية للجهة الخارجية NPAPI للعرض و 2) وجود واجهة لرفع عدة ملفات في Content Collection، على الرغم من دعم الواجهات الأخرى الخاصة برفع عدة ملفات على هذه المستعرضات.

    *** Internet Explorer غير مدعوم لواجهة Ultra أو طريقة عرض Ultra للمقرر الدراسي.


    الأجهزة وأنظمة التشغيل التي خضعت للاختبار

    تم استخدام مجموعة متنوعة من الأجهزة وأنظمة التشغيل لاختبار المستعرضات المدعومة. ولا يقتصر الدعم على أنظمة التشغيل المحددة هذه. إن إصدارات مستعرضات سطح المكتب المذكورة أعلاه مدعومة بصرف النظر عن الجهاز أو نظام التشغيل المحدد الذي تعمل عليه هذه الإصدارات.

    الأجهزة المُستخدمة للاختبار
    الفئةتم اختباره
    أنظمة التشغيلWindows 7، وWindows 8، وWindows 10، وMac OS 10.8، وMac OS 10.9، وMac OS 10.10، وiOS، وAndroid، وWindows Mobile، وChrome OS
    أجهزة iOSiPod Touch، وiPhone 4S، وiPhone 5S، وiPhone5c، وiPhone 6، وiPad 2، وiPad 3, وiPad Mini 3، وiPad Air 2
    أجهزة AndroidGalaxy S4، وGalaxy S5، وHTC G1، وLG C800 myTouch، وHTC One، وGalaxy Note 2014، وHTC One M8
    أجهزة Windows MobileVenue 8 Pro، وLumia 520، وLumia 930
    أجهزة Chrome OSChromebook (مستعرض Chrome؛ الميزات التي تتطلب مكونات إضافية من النوع NPAPI غير مدعومة)

    تسعى Blackboard جاهدة لتوفير إمكانية الوصول إلى جميع منتجاتها قدر الإمكان. يستخدم أحدث إصدارين متاحين من JAWS أثناء اختبار إمكانية الوصول لكل إصدار من إصدارات Blackboard Learn.

    المكونات الإضافية الخاصة بـ Java والمستعرضات الأخرى

    تتطلب مجموعة من ميزات Blackboard Learn تثبيت برنامج إضافي معين. وبدون هذه البرامج الإضافية، لا تعمل الميزات نفسها. تتطلب الميزات التالية لـ Blackboard Learn شروط المكونات الإضافية التالية:

    • تتطلب عمليات تحميل الملفات المتعددة في "ملفات المقرر الدراسي" وContent Collection وجود "بيئة تشغيل Java"‏ (JRE) من Oracle الممكّنة كمكون إضافي للمستعرض. لا تتطلب أداة تحميل ملف واحد هذا المتطلب. تم توقيع التطبيق الصغير للرفع بواسطة Blackboard ويتضمن مرجع الطابع الزمني الذي يسمح للتطبيق الصغير بالتشغيل حتى بعد انتهاء صلاحية الشهادة.
    • ميزات الاتصال المتزامنة المتوفرة في حجرة المقرر الدراسي وBlackboard Collaborate، المتاحة عبر Building Block، تتطلب تحميل Blackboard Collaborate Launcher وتثبيته ولكنها لا تتطلب المكون الإضافي للمستعرض Java JRE.

      المشغل ليس مطلوبًا إلا لـ Blackboard Collaborate المزود بالتجربة الأصلية. لا يتطلب استخدام Blackboard Collaborate مع Ultra القيام بأي عمليات تنزيل.

    يعد الإصداران 7 و8 من JRE الإصدارين الموصى بهما للميزات التي تعتمد بيئة JRE. قد يعمل الإصدار 6 من JRE، لكن قد يتسبب في حدوث سلوك غير متوقع. تقر Oracle بوجود بعض المشكلات المتعلقة بالأمان مع الإصدار 6 من JRE.

    لا يتطلب Blackboard Learn أية مكونات إضافية أخرى للمستعرض. لمعرفة المزيد حول المكونات الإضافية للمستعرض والتكنولوجيا المساعدة وبرامج الدعم الأخرى، راجع موضوع سياسة دعم المستعرض في هذا القسم.


    التحليلات الخاصة بدعم مستعرضات Learn

    يتم توفير التقارير والتصورات المتاحة في تحليلات تطبيق Learn عبر أدوات معلومات مهنية تنتمي لجهات خارجية مقدّمة من شركاء Blackboard، وخاصة Microsoft (أداة Reporting Services) للتقارير المضمّنة والأداة الهرمية (الأداة الهرمية من BI Office) لإنشاء لوحات المعلومات. لدى هذه المنتجات التزاماتها الخاصة لدعم المستعرضات. لذا، تخضع التفاصيل التالية للتغيير استنادًا إلى قرارات المنتجات التي يتخذها شركاؤنا.

    إن تقارير التحليلات الخاصة بتطبيق Learn والتي يتم عرضها داخل واجهة Learn مدعومة في جميع المستعرضات ذاتها التي يعمل عليها تطبيق Learn. كما إن التقارير المستقلة لـ Microsoft Reporting Services مدعومة في نفس مستعرضات Learn. راجع موقع الويب الخاص بـ Microsoft للحصول على معلومات إضافية عن دعم المستعرضات لأداة Microsoft Reporting Services.

    لعرض لوحات المعلومات الهرمية، يلزم توافر مستعرض متوافق مع HTML-5. لا تتوافق الإصدارات القديمة من Internet Explorer التي استغنت عنها Microsoft مع عرض التقارير الهرمية. لإنشاء لوحات المعلومات الهرمية، يلزم توافر مستعرض متوافق مع NPAPI لأن أداة إنشاء الهرم تستخدم المكون الإضافي Microsoft Silverlight. قام Google Chrome بالاستغناء عن دعم NPAPI. لذلك، هذا المستعرض غير متوافق. ويجب على مستخدمي Firefox أو Safari تثبيت وتكوين المكون الإضافي Silverlight لاستخدامه مع هذين المستعرضين.


    ملاحظات التكوين

    • إن مستعرض Internet Explorer مدعوم فقط في الوضع القياسي.
    • برنامج Java في الإصدار 10.8 من نظام التشغيل Mac OS X أو الإصدارات الأعلى في الواجهات الأصلية لتطبيق Blackboard Learn 9.1: لن يتم تضمين Java كجزء من عملية تثبيت نظام التشغيل بعد الآن، ويجب تنزيله وتثبيته بواسطة المستخدمين عند مطالبتهم بذلك من قِبَل التطبيق/التطبيق الصغير. يتم هذا الإجراء من جانب المستخدم مرة واحدة فقط.

    التغييرات الطارئة على تقنيات العميل من الإصدارات السابقة

    • انتهى دعم المستعرض Internet Explorer 10.
    • ومن المقرر أن يكون توسيع دعم التعريف حسب أنواع وإصدارات المستعرضات شاملاً أنظمة التشغيل والتنسيقات الإضافية، بما في ذلك الأجهزة الجوالة والأجهزة اللوحية.

    التقنيات غير المدعومة

    • Windows XP
    • لا تعمل أنظمة التشغيل Windows وMac OS وLinux باستخدام مستعرض مدعوم
    • الإصدار 10 فأقل من مستعرض Internet Explorer، وهي إصدارات لم تعُد مدعومة من قِبَل Microsoft؛ ومستعرض Internet Explorer في الأجهزة الجوالة
    • الإصدار 30 فأقل من Firefox في أجهزة سطح المكتب، وجميع إصدارات Firefox في الأجهزة الجوالة
    • الإصدار 35 فأقل من مستعرض Chrome (الإصدار 34 فاقل في الأجهزة الجوالة)
    • الإصدار 5 فأقل من مستعرض Safari
    • الإصدار 5 من بيئة JRE لواجهات المستخدم الأصلية لتطبيق Blackboard Learn

    دعم الواجهات التي تعمل باستخدام الواجهة الأصلية

    ينطبق هذا القسم على مستخدمي Blackboard Learn SaaS فقط.

    لم يتم تحديث بعض واجهات المستخدم في تطبيق Blackboard Learn في نشر SaaS بواجهات Ultra حتى الآن. تتضمن هذه الواجهات، على سبيل المثال لا الحصر، المناطق التالية:

    • "طريقة العرض الأصلية للمقرر الدراسي" - باستخدام طريقة العرض الأصلية للمقرر الدراسي لـ Blackboard Learn 9.1
    • مناطق تكوين المسؤول
    • Content Collection
    • استطلاعات Enterprise
    • مدير الأهداف
    • ميزات تقييم Outcomes

    هذه الواجهات التي تعمل باستخدام الواجهة الأصلية غير مدعومة للعمل مع الأجهزة اللوحية والأجهزة المحمولة، وذلك على الرغم من احتمالية نجاح المستخدمين في تشغيلها على هذه الأجهزة.