تنطبق هذه المعلومات على طريقة العرض الأصلية للمقرر الدراسي فقط. تتحكم مؤسستك في تحديد الأدوات التي تتم إتاحتها.

حول قائمة المصطلحات وملفات قائمة المصطلحات

يمكنك إضافة قائمة المصطلحات لكل مقرر من المقررات الدراسية الخاصة بك. بحيث يتكون كل إدخال من مصطلح وتعريف. وبإمكانك أنت ومؤسستك التحكم في هذا الأمر في حالة توفر أداة قائمة المصطلحات.

إذا كنت تخطط لإنشاء قائمة مصطلحات ضخمة، يمكنك رفع ملف يحتوي على جميع المصطلحات أو معظمها، ثم قم بتحديث قائمة المصطلحات بإضافة المزيد من المصطلحات حسب الحاجة. يمكنك أيضًا إضافة المصطلحات الخاصة بقائمة المصطلحات المصطلح تلو الآخر لإعداد قائمة مصطلحات قصيرة أو عند الرغبة في إضافة مصطلحات إلى قائمة مصطلحات موجودة.

لإنشاء ملف قائمة مصطلحات للرفع، اكتب المصطلحات والتعريفات في برنامج لجداول البيانات، مثل Microsoft® Excel®‎. ويتعين عليك إضافة مصطلح واحد وتعريف واحد في كل سطر، بحيث يوجد المصطلح في عمود والتعريف في العمود الذي يليه. احفظ الملف بتنسيق CSV (قيم مفصولة بفاصلة). بدلًا من ذلك، استخدم محرر نصوص بسيط لإنشاء ملف قائمة المصطلحات. بوجود إدخال لكل سطر، استخدم الفاصلة أو علامة الجدولة لفصل المصطلح عن التعريف. ثم، احفظ الملف بتنسيق CSV أو TXT.

بعد قيامك بإنشاء ملف قائمة المصطلحات الخاص بك، قم برفعه باستخدام أداة قائمة المصطلحات. يُصبح لديك الخيار إما بتحديث قائمة مصطلحات موجودة أو استبدالها.

في حالة وجود مصطلحات مكررة في الملف الذي تم تحميله، فستحل محل تلك المصطلحات الموجودة في قائمة المصطلحات.


تنسيق ملف قائمة المصطلحات

يتم فصل كل إدخال بحرف نهاية سطر داخل الملفات بتنسيق CSV، بالإضافة إلى أنه يتم فصل المصطلح والتعريف بفاصلة.

مثال 1:

"Apple","A red fruit."

"Onion","A vegetable."

وبالرغم من أنه ليس من الضروري في كل الأحوال وضع المصطلح والتعريف داخل علامات اقتباس، إلا أن Blackboard توصي بشدة بهذا الإجراء وذلك لتجنب حدوث أخطاء أثناء المعالجة.

مثال 2:

"Apple","A delicious fruit, usually <b>red</b&gt; in color. Apples are grown all over the world and are an important religious and mythical symbol to several cultures. The Pacific Northwest region of the United States, particularly Washington state, is famous for its apples.<br><br&gt; However, most refined apple lovers agree that the best apples come from the Hudson River valley area of New York. Perhaps this is why New York City is nicknamed, ""The Big Apple."""

"Onion","Onions are a tasty vegetable with green stalks and a white, yellow, or red bulb. For the best-tasting onions, visit the \"Onion Capital of the World\" Pine Island, New York."

يجب تجاهل علامات الاقتباس التي تظهر مع تعريف أو مصطلح. يجب تحديد علامة الاقتباس كجزء من التعريف وإلا سيتم قراءة العلامة على أنها نهاية التعريف. قم بتجاهل علامات الاقتباس عن طريق استخدام خط مائل عكسي ("\)، أو باستخدام مجموعة أخرى من علامات الاقتباس ("").

الملفات الدُفعية

الملفات الدُفعية هي عبارة عن ملفات بامتداد TXT تحتوي على قدر كبير من المعلومات التي يمكنك رفعها إلى النظام. تحتوي كل أداة مساعدة للملفات الدفعية على إرشادات معينة حول إنشاء الملف الدُفعي. تعد مقاييس الملفات الدُفعية التالية مقاييس عالمية:

  • يجب أن تكون جميع الملفات بأحد النوعين المدعمين للملفات: CSV أو TXT. يقوم إصدار 2003 لـ Microsoft Excel والإصدارات الأحدث منه بإدراج علامات اقتباس مزدوجة في كل حقل تلقائيًا عند حفظ ورقة العمل على هيئة ملف بتنسيق CSV.
  • يجب أن يكون كل ملف بتنسيق DOS. أما الملفات بتنسيق MAC أو UNIX فيجب تحويلها إلى DOS.
  • يجب وضع الحقول داخل علامات اقتباس مزدوجة. على سبيل المثال: "ENG_201"
  • عند ظهور علامات اقتباس في أحد الحقول، استخدم حرف هروب لتوضيح أن الحرف التالي لا يشير إلى نهاية الحقل. حرف الهروب هو خط مائل عكسي (\). على سبيل المثال: "\"ENG_201\""
  • يجب فصل كل حقل بأحد هذه الفواصل: فاصلة، أو نقطتين، أو علامة جدولة عند تحديد "تلقائي"، يمكن استخدام نوع واحد من الفواصل فقط في كل ملف دُفعي. على سبيل المثال: "ENG_201" ،"أدب إنجليزي" أو "ENG_201" :"أدب إنجليزي"
  • يجب أن يكون كل سجل بسطر منفصل. على سبيل المثال:
    ‎"ENG_201","English Literature"
    "ENG_201","English Literature"‎
  • لا تقم بتضمين أسطر فارغة بين السجلات. سيتم معالجة السطر الفارغ وسيؤدي إلى ظهور خطأ.
  • تُوصي شركة Blackboard بعدم تجاوز عدد السجلات في كل ملف دُفعي 500 سجل نظرًا لقيود نفاد المهلة المقترنة بمعظم المستعرضات.

رفع ملف قائمة المصطلحات أو تنزيله

لوحة التحكم > أدوات المقرر الدراسي > قائمة المصطلحات

  1. في صفحة المسرد، حدد تحميل/تنزيل للوصول إلى القائمة وحدد تحميل 'المسرد'.
  2. في الصفحة تحميل 'المسرد' قم بالاستعراض لتحديد موقع الملف على جهاز الكمبيوتر الخاص بك أو في مستودع ملفات المقرر الدراسي: "ملفات المقرر الدراسي" أو Content Collection.
  3. حدد خيارًا من خيارات حفظ المصطلحات الحالية:
    • إضافة المصطلحات الموجودة في هذا الملف لقائمة المصطلحات: استخدم هذا الخيار لتكملة قائمة المصطلحات الموجودة التي تحتوي على قائمة بالمصطلحات الجديدة. وفي حالة ظهور مصطلح في كل من قائمة المصطلحات الموجودة والملف، فسيحل التعريف الموجود في الملف محل التعريف الموجود في قائمة المصطلحات الموجودة. وفي حالة ظهور نفس المصطلح مرتين أو أكثر في الملف، فسيظهر في قائمة المصطلحات آخر تعريف للمصطلح.
    • حذف كل مصطلحات قائمة المصطلحات واستبدالها بكل مصطلحات هذا الملف: استخدم هذا الخيار لحذف قائمة المصطلحات الموجودة واستبدالها بالمصطلحات الموجودة بالملف.
  4. حدد إرسال.

في وضع التحرير، يمكنك التحقق من المصطلحات قبل إتاحة قائمة المصطلحات للطلاب.

تنزيل قائمة المصطلحات

يمكنك تنزيل قائمة المصطلحات لإضافة المصطلحات إلى مقرر دراسي آخر. ويمكنك تحرير قائمة المصطلحات دون اتصال ثم رفعها إلى مقرر دراسي آخر.

عند قيامك بتنزيل قائمة مصطلحات، يتم إنشاء ملف بيانات قيم مفصولة بفاصلة (CSV) من قائمة المصطلحات. ويتم فصل كل إدخال بعلامة رجوع لأول السطر داخل كل إدخال، ويتم فصل المصطلح والتعريف بفاصلة.

يمكنك تحرير قائمة المصطلحات في أحد برامج جداول البيانات أو في محرر النصوص. تأكد من الحفاظ على تنسيق الملف كما هو لضمان سهولة التحميل.

  1. في صفحة المسرد، حدد تحميل/تنزيل للوصول إلى القائمة وحدد تنزيل المسرد.
  2. في الصفحة تنزيل المسرد، حدد تنزيل.
  3. في النافذة المنبثقة، حدد حفظ باسم وحدد موافق لحفظ ملف قائمة المصطلحات إلى جهاز الكمبيوتر الخاص بك.

إنشاء مصطلحات قائمة المصطلحات

  1. في صفحة المسرد، حدد إنشاء مصطلح.
  2. من الصفحة إنشاء مصطلح، اكتب المصطلح والتعريف. اختياريًا، استخدم المدقق الإملائي الموجود في المحرر.
  3. حدد إرسال.

إضافة رابط قائمة المصطلحات إلى قائمة المقرر الدراسي

يمكنك إضافة رابط إلى قائمة المقرر الدراسي للوصول الفوري إلى أداة قائمة المصطلحات. ويمكنك أيضًا تخصيص اسم الارتباط.

  1. في وضع التحرير، حدد الرمز إضافة عنصر قائمة الموجود بأعلى قائمة المقرر الدراسي.
  2. في القائمة، حدد ارتباط بأداة واكتب اسماً للرابط.
  3. من قائمة النوع، حدد المسرد.
  4. حدد خانة الاختيار متاح للمستخدمين.
  5. حدد إرسال.

يظهر رابط الأداة الجديد في آخر قائمة المقرر الدراسي. اختياريًا، اضغط على الرابط واسحبه إلى موقع جديد. قم بالوصول إلى قائمة الروابط لإعادة تسمية الرابط أو حذفه أو إخفائه عن الطلاب.