Blackboard Collaborate is committed to making the online teaching and learning experience consistent across all supported browsers

Browser support

Supported browsers

Collaborate Browser Version Support Policy

What do we mean by support?

Support means that we have tested the release of Collaborate on the latest two versions of the supported browsers and have validated the experience on those versions only.

Overall, considering permutations of browser types, versions, and computer operating systems, each release is tested with dozens of configurations. Supporting the latest two versions of main browsers is the target we're able to set while maintaining reasonable release cycles. Adding more versions would mean adding more testing time and thus releasing features later for all clients.

While you can in most cases join a session with some version older than the last two, you may not get the best experience and we can't guarantee the use of Collaborate with those.

Users on older browser versions can still submit support requests for issues they encounter. The Blackboard Support team will try to replicate the issue with supported browsers and if it can’t be replicated, will recommend updating the browser to a current version which would solve the issue.

Version support

As part of our commitment to a consistent experience across browsers, Collaborate only supports the two most recent stable channel releases of browsers.

Older browser versions can introduce issues that may or may not get fixed by the companies that release the browser.

  • Performance: Older browser versions can have issues that impact the performance of Collaborate.
  • Security: Older browser versions could have known security issues and flaws that are made public. These issues can be exploited and put us and our users at risk.
  • Outdated technology: Older browser versions can be outdated and not have the technology and functionality required for Collaborate.

Often browser companies fix the issue in a newer release and eventually end support on the older versions. As a result, Collaborate tests and validates the two most recent stable versions of the supported browsers.

Disabled versions

In some particular cases, we're forced to prevent some old browsers from accessing Collaborate. We understand the workload that upgrading browsers can represent for an institution, and we never take this decision lightly, and provide as much advance warning as we can. This is only done when the browser is causing severe issues.

  • Inconsistent user experience. Users won’t get a critical feature available in other browsers.
  • High disconnection rates that prevent users from fully participating in a session.
  • Critical issues with the older browser that we can’t fix nor find workarounds for but was fixed in a newer browser version.
  • Potential security risks.

While it can be inconvenient to have to upgrade browsers for a whole institution, whenever we're having to disable a browser it is ultimately to prevent your users from being in a situation where they would get a significantly bad user experience with this browser.