Browser Support

On this page

    Browser Support

    Blackboard Collaborate with the Ultra experience is based on modern web technologies including HTML 5 and WebRTC. You don't need to install Java or a launcher.

    For the best experience use Google ChromeTM or Firefox® (versions 52+).

    For the best Blackboard Collaborate experience with your screen reader use Firefox® and Jaws on a Windows® system. On a Mac® use Safari® and VoiceOver. Visit the Accessibility topic to learn more about Blackboard's approach to accessible software.

    Browser support
    Browser Audio/Video Application Sharing
    ChromeTM versions 54+

    On Windows® and Mac®

    Supported with High Quality

    Shows most videos in conference layout

    See 5 videos: four speakers and your own

    Share and View
    Firefox® with WebRTC versions 55+

    On Windows, Mac, and Linux®

    See 3 videos: two speakers and your own Share and View
    Firefox®

    On Windows, Mac, and Linux®

    With Flash® versions 17+

    See 2 videos: the speaker and your own View Only
    Safari®

    With Flash versions 17+

    See 2 videos: the speaker and your own View Only
    Internet Explorer®

    With Flash versions 17+

    IE 10 is not supported. To learn more see the Behind the Blackboard IE 10 in Collaborate Ultra article. (available in English only)

    See 2 videos: the speaker and your own View Only
    Microsoft Edge®

    With Flash versions 17+

    See 2 videos: the speaker and your own View Only

    Mobile devices

    Browsers on mobile devices are supported on Windows® touch devices such as the Surface at this time. Users can choose to use the Blackboard app, Blackboard Instructor, or the device browser.

    More on browser support on Behind the Blackboard (available in English only)